Mettre à jour le plugin Flash sous Debian

J’ai récemment eu un petit problème avec Flash, Youtube m’avertissant que le plugin Flash n’était pas à jour !

Vous pouvez vérifier que vous avez la dernière version :
# update-flashplugin-nonfree --status
Flash Player version installed on this system : 11.2.202.406
Flash Player version available on upstream site: 11.2.202.425

En effet, une nouvelle version de Flash est disponible et fixe des problèmes de sécurité dont notamment le CVE-2014-9163 déjà en cours d’exploitation en décembre.

Vous pouvez mettre à jour par cette commande en root:
# update-flashplugin-nonfree --install

Il faudrait vraiment que le plugin Flash se mette à jour tout seul sous Debian à chaque nouvelle version d’Adobe !

18 réactions sur “ Mettre à jour le plugin Flash sous Debian ”

  1. Gilles

    Faudrait plutôt arrêter d’utiliser Flash.
    Surtout sur YT dont 95% des vidéos sont lisibles avec le lecteur HTML5 du site…

  2. AlexP

    Il faudrait vraiment que le plugin Flash se mette à jour tout seul sous Debian à chaque nouvelle version d’Adobe !

    Et puis quoi encore!?! Pourquoi pas installer windows tant qu’on y est, et puis aussi laisser ces trucs tripoter ta machine sans aucun contrôle.

  3. Sabcat

    Ha bien cool. Je me demandais ce que c’était que ce message d’erreur sous FF.
    A noté que j’ai le même soucis sur Win7 et FF à jour.

  4. 2passage

    Bonjour.
    Vous tombez à pic !!
    J’ai ce message depuis quelques jours sous Firefox également.
    Ce que je ne comprends pas, c’est pourquoi les classiques : apt-get update ; apt-get upgrade ne font pas le travail ?!
    Si quelqu’un à des explications.

    Je ne connaissais pas ces commandes. Merci ! j’suis à jour maintenant !!!

    Pour les autres: c’est vrai pour flash/HTML5 mais perso j’ai une carte son externe USB pour faire des enregistrements – et avoir une meilleur qualité de son lors de la lecture que le chip médiocre de la carte mère – je passe donc par Jack, et le HTML5…rien à faire, j’ai pas de son, toutes les vidéos sur viméo ne fonctionnent pas pour moi (du moins le son, l’image impec ! ) par exemple.

    Merci encore.

    Cordialement.

  5. Tuxicoman Auteur Article

    Je suis d’accord qu’il faudrait désinstaller Flash,
    Je l’ai installé mais je ne l’active que quand c’est nécessaire donc vraiment pas souvent.

    Le paquet Debian va juste télécharger le plugin sur le site d’Adoble lors de son installation (apt-get install)
    Mais ensuite, aucune mise à jour n’est faite.

    Il y a eu une discussion avec le mainteneur de paquet pour qu’il sorte une nouvelle version mineure à chaque mise à jour d’Adobe, Ainsi apt irait télécharger la nouvelle version à chaque mise à jour du paquet.

  6. gilgam

    Merci !
    j’ai en effet ce message d’erreur sur les pc sous Linux de la famille.
    Flash est un mal nécessaire et littéralement vital pour le grand public.
    J’ai installé du linux chez des amis, de la famille sans problèmes, mais leur dire maintenant, « ah oui au fait tu ne pourras pas jouer les petits jeux flash, voir les videos etc.  » c’est impensable.

  7. Gilles

    @gilgam : Non, Flash n’est pas vital. Mais chacun son utilisation. Et pour info, la version 11.2 accessible en apt-get fait très bien marcher les jeux Facebook.

    D’ailleurs, de manière générale, je n’ai pas encore vu de nécessité de passer en 11.6…
    Le jour où Adobe imposera une version 11.3 ou pus, on va rigoler :)

  8. François

    Pour ma part, à mon très humble niveau, je téléchargeais l’archive pour linux sur le site d’adobe, et je copiais le ficher libflashplayer.so dans la librairie avec la commande :
    # cp /home/user/Téléchargements/libflashplayer.so /usr/lib/mozilla/plugins/
    Mais là, même en supprimant ce fichier / redémarrer / installer le nouveau, ça fonctionnait pas.
    Du coup j’ai installé le plugin flashplugin-nonfree… tjrs pas…
    Mais une petite màj générale (# apt-get update / upgrade), et ça y est !!!
    :-)
    Peut-être que c’était la màj générale qui manquait (ça fonctionnait pourtant très bien jusque là), mais en tout cas, ça sera plus simple la prochaine fois.
    Merci Tuxicoman.

  9. Ping Installation d’Adobe Flash Player sur debian jessie | Mon Debian

  10. JF

    Bonjour, et merci pour la commande.

    Pour ce qui est des commentaires anti adobe-flash, je pense que vous desservez la cause du libre en faisant cela.
    L’utilisateur lambda d’un ordinateur veut que ça marche sans faire trop d’effort. Ne pas installer flash c’est effectivement avoir un message d’erreur sur un site sur 3 ou 4. Chercher à contourner flash, c’est perdre un temps considérable, juste pour une partie des sites, en plus.

    Donc, tant que linux ne propose pas quelque chose d’universel ou presque pour contourner flash, il faut se relaxer sur le sujet; car ce comportement qui consiste à fustiger « ceux qui ne seraient pas purs »
    risque de détourner les gens de linux (les gens ne veulent pas se prendre la tête avec ces futilités, en général).
    C’est en cela que c’est contreproductif.

  11. Ping Mises à jour linuxiennes, suite et fin | Parigot-Manchot

  12. 2passage

    Hello.
    La mise à jour ne fonctionne plus (chez moi, Debian 7)
    Quelqu’un à une solution ? Même problème ?
    Cordialement.

    update-flashplugin-nonfree –status

    Flash Player version installed on this system : 11.2.202.626
    Flash Player version available on upstream site: 22.0.0.209

    update-flashplugin-nonfree –install

    already exists: /usr/bin/flash-player-properties
    already exists: /usr/share/applications/flash-player-properties.desktop
    already exists: /usr/share/icons/hicolor/16×16/apps/flash-player-properties.png
    already exists: /usr/share/icons/hicolor/22×22/apps/flash-player-properties.png
    already exists: /usr/share/icons/hicolor/24×24/apps/flash-player-properties.png
    already exists: /usr/share/icons/hicolor/32×32/apps/flash-player-properties.png
    already exists: /usr/share/icons/hicolor/48×48/apps/flash-player-properties.png
    already exists: /usr/share/pixmaps/flash-player-properties.png

  13. Anonyme

    il ne faut s’étonner que Linux plafonne à 2.5 %. Entre les mises à jour qui ne fonctionnent pas où l’on est « obligé » de faire confiance à des personnes que l’on ne connaît pas (passage de Ice… à Firefox) les fichiers que l’on ne peut modifier car on n’ a pas les autorisations et les plugin obsolète que l’on ne sait pas comment traiter. Mise à jour de Firefox ou du plugin concerné

  14. 2passage

    @Anonyme

    Oh le gros troll velu ! Je pourrais facilement te répondre et demonter tes remarques (on va pas appeler ça des arguments hein, faut pas déconner, mais…j’ai la vaisselle à faire et mon chat à brosser.

    @Tuxicoman : Je dirais même plus : Champagne ! En route pour les 5% vers l’infini et au-delà.

    A+ les zamis

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.