GooglePlayDownloader 1.5

Je viens de sortir une mise à jour pour le GooglePlayDownloader, logiciel libre pour télécharger les APK du GooglePlay store (sans vous demander votre compte Google).

-Nouveaux identifiants valides pour se connecter au GooglePlay
-Résolution des dépendances pour installation sur Debian Jessie
-Python2 est appelé explicitement pour ceux qui utilisent Python3 par defaut
-Corrige la génération d’AndroidID pour certaines configurations de Java.

Le téléchargement se passe par là : .deb et source

8 réactions sur “ GooglePlayDownloader 1.5 ”

  1. jerry wham

    Je suis sous LinuxMint 16 et j’ai pu installer la mise à jour en téléchargeant python-ndg-httpsclient.
    J’ai bien le raccourci dans mon menu applicatif, mais rien ne s’affiche à l’écran quand je double clique sur l’icone.

  2. Tuxicoman Auteur Article

    Tu peux le lancer en ligne de commande, tu auras peut être une erreur plus explicite :
    $ googleplaydownloader

  3. brother

    Salut à tous,
    ça ne marche plus : server says : needsbrowser
    Et vous ???

  4. Tuxicoman Auteur Article

    Si tu changes l’adresse Gmail ca fonctionne. Je vais ressortir une version avec des nouveaux identifiants par défaut.

  5. jerry wham

    Voici ce que me donne le terminal :

    Traceback (most recent call last):
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/googleplaydownloader.py », line 621, in
    main()
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/googleplaydownloader.py », line 608, in main
    app = App()
    File « /usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py », line 7981, in __init__
    self._BootstrapApp()
    File « /usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py », line 7555, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/googleplaydownloader.py », line 598, in OnInit
    fen = MainFrame(self, title)
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/googleplaydownloader.py », line 592, in __init__
    self.panel.connect_to_googleplay_api()
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/googleplaydownloader.py », line 418, in connect_to_googleplay_api
    api.login(config[« gmail_address »], config[« gmail_password »], AUTH_TOKEN)
    File « /usr/lib/python2.7/dist-packages/googleplaydownloader/ext_libs/googleplay_api/googleplay.py », line 125, in login
    response = requests.post(self.URL_LOGIN, data=params, headers=headers, verify=True)
    File « /usr/lib/python2.7/dist-packages/requests/api.py », line 88, in post
    return request(‘post’, url, data=data, **kwargs)
    File « /usr/lib/python2.7/dist-packages/requests/api.py », line 44, in request
    return session.request(method=method, url=url, **kwargs)
    File « /usr/lib/python2.7/dist-packages/requests/sessions.py », line 456, in request
    resp = self.send(prep, **send_kwargs)
    File « /usr/lib/python2.7/dist-packages/requests/sessions.py », line 559, in send
    r = adapter.send(request, **kwargs)
    File « /usr/lib/python2.7/dist-packages/requests/adapters.py », line 382, in send
    raise SSLError(e, request=request)
    requests.exceptions.SSLError: hostname ‘android.clients.google.com’ doesn’t match either of ‘*.google.com’, ‘*.android.com’, ‘*.appengine.google.com’, ‘*.cloud.google.com’, ‘*.google-analytics.com’, ‘*.google.ca’, ‘*.google.cl’, ‘*.google.co.in’, ‘*.google.co.jp’, ‘*.google.co.uk’, ‘*.google.com.ar’, ‘*.google.com.au’, ‘*.google.com.br’, ‘*.google.com.co’, ‘*.google.com.mx’, ‘*.google.com.tr’, ‘*.google.com.vn’, ‘*.google.de’, ‘*.google.es’, ‘*.google.fr’, ‘*.google.hu’, ‘*.google.it’, ‘*.google.nl’, ‘*.google.pl’, ‘*.google.pt’, ‘*.googleadapis.com’, ‘*.googleapis.cn’, ‘*.googlecommerce.com’, ‘*.googlevideo.com’, ‘*.gstatic.cn’, ‘*.gstatic.com’, ‘*.gvt1.com’, ‘*.gvt2.com’, ‘*.metric.gstatic.com’, ‘*.urchin.com’, ‘*.url.google.com’, ‘*.youtube-nocookie.com’, ‘*.youtube.com’, ‘*.youtubeeducation.com’, ‘*.ytimg.com’, ‘android.com’, ‘g.co’, ‘goo.gl’, ‘google-analytics.com’, ‘google.com’, ‘googlecommerce.com’, ‘urchin.com’, ‘youtu.be’, ‘youtube.com’, ‘youtubeeducation.com’

  6. Tuxicoman Auteur Article

    La vérification du certificat SSL de google a échoué et donc la communication ne se fait pas (le téléchargement se fait HTTPS avec les serveurs de Google pour une bonne sécurité)

    Le problème vient la librairie qui fait la vérification des certificats SSL en python, Si tu passes à une version plus récente de LinuxMint tu ne devrais plus avoir ce problème.

  7. monpseud0

    BOnjour,
    téléchargement et installation sans problème. En revanche, après téléchargement des apk, impossible de les installer sur mon téléphone. Message « un problème est survenu lors de l’analyse du kit ».
    Avez-vous une solution? Merci d’avance!

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.